Results 1 to 2 of 2

Thread: Advanced Deck 5500 Unresponsive (Heat?)

  1. #1

    Advanced Deck 5500 Unresponsive (Heat?)


    I have a 5500 panel in my 2012 kit Searey. I am not the builder. I've owned it for a year and it's been working great.

    I picked up the plane from annual last week, while there my AP fixed a fuel tank sender issue, that required him to repopulate the table for fuel values. Everything still worked fine, including my fuel gauge. Nice.

    Last night. I landed on the river after flying ~10 minutes and powered down. When I turned the master back on, and the 5500 booted. I couldn't select "I agree" on the splash screen. The button was unresponsive. I rebooted the aircraft. Same thing. Tried pulling the breaker for the panel and waiting and still got the same thing. Eventually I just waited until the splash screen disappeared but my engine monitor gauges were missing, and the ENGINE button was also not functional (physical button, 2nd from left)... Every other button seemed to work. The display was responsive and heading, airspeed, etc.. were all correct and updating. But I couldn't turn on engine gauges. Rebooted again, and same thing. No way to "I Agree". Flew home no engine gauges.

    Came out this AM to try and troubleshoot and the problem was gone. "I accept" worked fine, as did all my other buttons. Left the panel turned on for ~20 minutes while I read the manual and tried to look through settings. Rebooted the panel and the problem happened again. Seems to be after the panel is on for some time, then rebooted, I lose those buttons?

    So I thought, maybe it's heat related? Overheating and crashing? But I hear the fans running behind the panel, and the panel is still working, just some of the buttons stop working...

    Here's a video of it happening at the splash screen:

    Here's a video of it booted on the EFIS page, but the ENGINE button being unresponsive while everything else seems to work fine:

    It's running original software I believe (X8.16.17-MV16) but it's been working fine and I didn't want to touch something that was functioning properly (until now).

    Any ideas?
    Last edited by rallymatt; 05-12-2023 at 12:31 PM.

  2. #2
    While that software is ancient, this is not a software problem. It may be heat related, but given the precedent with Seareys it is probably more likely to be corrosion than anything else. Please email to set up an RMA for return and repair of the EFIS, thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts